Ahmed Essam

Sign in

When I first started learning database systems, I ran into problems dealing with Arabic text in databases. Since these problems were specific to the Arabic language, I couldn’t easily find solutions on the internet. I try in this post to summarize the solutions I know to a common Arabic text problem in database systems, hoping it will help someone struggling to deal with Arabic text in databases.

You have characters which are considered the same in Arabic (like Alef 'ا' and Alef with Hamza 'أ'), but these are two different characters in database systems. When you try to make a…

Just posting a fix that took me hours of googling. While trying to install Ubuntu Server 20.04 on Virtual Box 6.1, and after mounting the Ubuntu Server ISO then starting the VM, I encountered this error:

Screenshot of the boot error

Turns out I reduced the RAM of the VM to be 512MB, adjusting the RAM to 768MB fixed it!

Thanks to @mrtumnus for posting his answer at serverfault:
https://serverfault.com/questions/1033384/qemu-ubuntu-server-20-04-initramfs-write-error

Hope I saved you some googling time!

Note: This tutorial requires Linux. If you want to test your flash under windows check out: test-and-detect-fake-flash-with-h2testw

So you have a corrupted flash memory, you copy files into it and when you try to open it later, they don’t work. There are number of reasons for this problem, one of them is aging, flash memories have a lifetime too and there is a limited number of writes. If this was the cause of the problem, then it is time to retire it. …

I recently made a clean install of Debian 10 (Buster). I migrated my emacs.d and .emacs hoping that everything will work as usual. I didn’t have much trouble with Emacs except for Jedi Server, which is responsible for Python auto-completion, has stopped working. It took me some time to fix this problem, and I am posting the fix hoping it will save someone else’s time.

Error Message

I tried to reinstall Jedi, the package installs fine, but when I tried jedi:install-server I got this error:

Running: pip install --upgrade /home/****/.emacs.d/elpa/jedi-core-20191011.1750/...Done
deferred error : (error "Deferred process exited abnormally:
command: /home/****/.emacs.d/.python-environments/default/bin/pip
exit…

Ahmed Essam

Web developer, Arabic Native, open-source enthusiastic, trying to do things the right way.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store